Ben_Pai | b24a3e5 | 2019-07-15 16:19:02 +0800 | [diff] [blame] | 1 | SUMMARY = "ID Button pressed application" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
Brad Bishop | d77088a | 2019-09-13 13:06:15 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Ben_Pai | b24a3e5 | 2019-07-15 16:19:02 +0800 | [diff] [blame] | 5 | |
| 6 | inherit obmc-phosphor-systemd |
| 7 | |
Brad Bishop | 5747dac | 2022-10-12 17:45:15 -0400 | [diff] [blame] | 8 | DEPENDS += "phosphor-gpio-monitor" |
| 9 | RDEPENDS:${PN} += "phosphor-gpio-monitor-monitor" |
Ben_Pai | b24a3e5 | 2019-07-15 16:19:02 +0800 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}" |
| 12 | SRC_URI += "file://toggle_identify_led.sh" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${bindir} |
| 16 | install -m 0755 ${WORKDIR}/toggle_identify_led.sh \ |
| 17 | ${D}${bindir}/toggle_identify_led.sh |
| 18 | } |
| 19 | |
Patrick Williams | e83c220 | 2021-09-01 16:17:33 -0500 | [diff] [blame] | 20 | SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/id_button" |
Ben_Pai | b24a3e5 | 2019-07-15 16:19:02 +0800 | [diff] [blame] | 21 | |
| 22 | ID_BUTTON_SERVICE = "id_button" |
| 23 | |
| 24 | TMPL = "phosphor-gpio-monitor@.service" |
| 25 | INSTFMT = "phosphor-gpio-monitor@{0}.service" |
| 26 | TGT = "multi-user.target" |
| 27 | FMT = "../${TMPL}:${TGT}.requires/${INSTFMT}" |
| 28 | |
Adriana Kobylak | b96c750 | 2021-08-06 16:25:30 +0000 | [diff] [blame] | 29 | SYSTEMD_SERVICE:${PN} += "id-button-pressed.service" |
Patrick Williams | e83c220 | 2021-09-01 16:17:33 -0500 | [diff] [blame] | 30 | SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'ID_BUTTON_SERVICE')}" |