Jayanth Othayoth | 942f57f | 2021-06-21 07:23:09 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools and libraries to manage the phal devicetree" |
| 2 | DESCRIPTION = "phal(power hardware abstraction layer) devicetree data \ |
| 3 | modelling mainly includes the host hardware topology and attributes, \ |
| 4 | which includes the configuration data" |
| 5 | |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 9 | |
| 10 | PDATA_DTB_PATH="${datadir}/pdata" |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 11 | FILES:${PN} += "${PDATA_DTB_PATH}" |
Jayanth Othayoth | 942f57f | 2021-06-21 07:23:09 -0500 | [diff] [blame] | 12 | |
| 13 | do_install() { |
| 14 | |
| 15 | DTB_FILE_ENV=power-target.sh |
| 16 | DTB_FILE_CONF_PATH=${D}${PDATA_DTB_PATH} |
| 17 | |
| 18 | install -d ${DTB_FILE_CONF_PATH} |
| 19 | install -m 744 ${THISDIR}/files/${DTB_FILE_ENV} ${DTB_FILE_CONF_PATH}/${DTB_FILE_ENV} |
| 20 | install -d ${D}${sysconfdir}/profile.d |
| 21 | ln -s ${PDATA_DTB_PATH}/${DTB_FILE_ENV} ${D}${sysconfdir}/profile.d/${DTB_FILE_ENV} |
| 22 | } |