blob: 1ebd2aa943b347a928fe8290629c440e9f2df7a2 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "DNS toolkit for Python"
2HOMEPAGE = "http://www.dnspython.org/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
5
Andrew Geissler5082cc72023-09-11 08:41:39 -04006SRC_URI[sha256sum] = "8dcfae8c7460a2f84b4072e26f1c9f4101ca20c071649cb7c34e8b6a93d58984"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8inherit pypi python_poetry_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23DEPENDS += "\
24 ${PYTHON_PN}-wheel-native \
25 ${PYTHON_PN}-setuptools-scm-native \
26"
27
28RDEPENDS:${PN} += " \
29 ${PYTHON_PN}-crypt \
30 ${PYTHON_PN}-io \
31 ${PYTHON_PN}-math \
32 ${PYTHON_PN}-netclient \
33 ${PYTHON_PN}-numbers \
34 ${PYTHON_PN}-threading \
35"