blob: a934d1c4615f428080a4c99d8f6bc526a8653c14 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "execnet: rapid multi-Python deployment"
5HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
8
Andrew Geissler595f6302022-01-24 19:11:47 +00009DEPENDS += "\
10 python3-pip-native \
Patrick Williams2a254922023-08-11 09:48:11 -050011 python3-hatch-vcs-native \
Andrew Geissler595f6302022-01-24 19:11:47 +000012"
Andrew Geissler69721092021-07-23 12:57:00 -040013
14SRC_URI += "file://run-ptest \
15 "
Patrick Williams2a254922023-08-11 09:48:11 -050016SRC_URI[sha256sum] = "cc59bc4423742fd71ad227122eb0dd44db51efb3dc4095b45ac9a08c770096af"
Andrew Geissler69721092021-07-23 12:57:00 -040017
Patrick Williams2a254922023-08-11 09:48:11 -050018inherit ptest pypi python_hatchling
Andrew Geissler69721092021-07-23 12:57:00 -040019
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/
23}
24
Patrick Williams213cb262021-08-07 19:21:33 -050025RDEPENDS:${PN}-ptest += "\
Andrew Geissler69721092021-07-23 12:57:00 -040026 python3-pytest \
27"
28
Patrick Williams213cb262021-08-07 19:21:33 -050029RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"
Andrew Geissler69721092021-07-23 12:57:00 -040030
31BBCLASSEXTEND = "native nativesdk"