blob: 87a173c8a22372a728c16560798b750ec35aea1b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
Patrick Williams2a254922023-08-11 09:48:11 -05007LIC_FILES_CHKSUM = "file://LICENSE;md5=cb819092901ddb13a7d0a4f5e05f098a"
Andrew Geissler517393d2023-01-13 08:55:19 -06008
Patrick Williams2a254922023-08-11 09:48:11 -05009SRC_URI[sha256sum] = "c02f372a88e0d17f36d3093a644c73cfc1788e876a7c4bcb4020a77512e2043c"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11inherit pypi setuptools3
12
13DEPENDS += " \
Patrick Williams2a254922023-08-11 09:48:11 -050014 ${PYTHON_PN}-cython-native \
15 ${PYTHON_PN}-numpy-native \
16 ${PYTHON_PN}-versioneer-native \
Andrew Geissler517393d2023-01-13 08:55:19 -060017"
18
Patrick Williams8e7b46e2023-05-01 14:19:06 -050019PACKAGESPLITFUNCS =+ "fix_cythonized_sources"
20
21fix_cythonized_sources() {
22 for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}`; do
23 if [ -e $f ]; then
24 sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f
25 fi
26 done
27}
28
Andrew Geissler517393d2023-01-13 08:55:19 -060029CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
30
31RDEPENDS:${PN} += " \
32 ${PYTHON_PN}-json \
33 ${PYTHON_PN}-numpy \
34 ${PYTHON_PN}-dateutil \
35 ${PYTHON_PN}-dateutil-zoneinfo \
36 ${PYTHON_PN}-pytz \
37 ${PYTHON_PN}-profile \
38"