blob: cd0e12ec8e36beda2579abcae3bf96083f999f7f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python bindings for DBus AT-SPI2 accessibility"
2DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca"
3SECTION = "devel/python"
4HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=db29218e6ba3794c56df7d4987dc7e4d \
7 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject"
9
10SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=master"
11SRCREV = "c9cb2a2289a6eb1fb95b66c25d5351bfea54c47e"
12
13S = "${WORKDIR}/git"
14
15# Same restriction as gtk+
16inherit features_check setuptools3
17ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
Patrick Williamse760df82023-05-26 11:10:49 -050018REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20inherit pkgconfig autotools python3native
21
22FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"
Patrick Williamsb542dec2023-06-09 01:26:37 -050023
24RDEPENDS:${PN} += "python3-pygobject"