Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python bindings for DBus AT-SPI2 accessibility" |
| 2 | DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca" |
| 3 | SECTION = "devel/python" |
| 4 | HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/" |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=db29218e6ba3794c56df7d4987dc7e4d \ |
| 7 | file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe" |
| 8 | DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject" |
| 9 | |
| 10 | SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=master" |
| 11 | SRCREV = "c9cb2a2289a6eb1fb95b66c25d5351bfea54c47e" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | # Same restriction as gtk+ |
| 16 | inherit features_check setuptools3 |
| 17 | ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}" |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 18 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | |
| 20 | inherit pkgconfig autotools python3native |
| 21 | |
| 22 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 23 | |
| 24 | RDEPENDS:${PN} += "python3-pygobject" |