blob: c63e75cf2e25b902916027b8fe49dfde965d650b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A toolkit to write, run and analyze benchmarks"
2DESCRIPTION = " \
3The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
4Features: \
5 * Simple API to run reliable benchmarks \
6 * Automatically calibrate a benchmark for a time budget. \
7 * Spawn multiple worker processes. \
8 * Compute the mean and standard deviation. \
9 * Detect if a benchmark result seems unstable. \
10 * JSON format to store benchmark results. \
11 * Support multiple units: seconds, bytes and integer. \
12"
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
15
Patrick Williams2a254922023-08-11 09:48:11 -050016SRC_URI[sha256sum] = "171aea69b8efde61210e512166d8764e7765a9c7678b768052174b01f349f247"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18DEPENDS += "${PYTHON_PN}-six-native"
19
20PYPI_PACKAGE = "pyperf"
Patrick Williams2a254922023-08-11 09:48:11 -050021inherit pypi python_setuptools_build_meta
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23RDEPENDS:${PN} += "${PYTHON_PN}-misc ${PYTHON_PN}-statistics"