Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A toolkit to write, run and analyze benchmarks" |
| 2 | DESCRIPTION = " \ |
| 3 | The Python pyperf module is a toolkit to write, run and analyze benchmarks. \ |
| 4 | Features: \ |
| 5 | * Simple API to run reliable benchmarks \ |
| 6 | * Automatically calibrate a benchmark for a time budget. \ |
| 7 | * Spawn multiple worker processes. \ |
| 8 | * Compute the mean and standard deviation. \ |
| 9 | * Detect if a benchmark result seems unstable. \ |
| 10 | * JSON format to store benchmark results. \ |
| 11 | * Support multiple units: seconds, bytes and integer. \ |
| 12 | " |
| 13 | LICENSE = "MIT" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8" |
| 15 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "171aea69b8efde61210e512166d8764e7765a9c7678b768052174b01f349f247" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | |
| 18 | DEPENDS += "${PYTHON_PN}-six-native" |
| 19 | |
| 20 | PYPI_PACKAGE = "pyperf" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 21 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | |
| 23 | RDEPENDS:${PN} += "${PYTHON_PN}-misc ${PYTHON_PN}-statistics" |