blob: e86a3c78981fc31c19b6343e31b34ab3c94d6329 [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "Style preserving TOML library"
2HOMEPAGE = "https://pypi.org/project/tomlkit/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82"
5
Patrick Williams2a254922023-08-11 09:48:11 -05006SRC_URI[sha256sum] = "38e1ff8edb991273ec9f6181244a6a391ac30e9f5098e7535640ea6be97a7c86"
Andrew Geissler3eeda902023-05-19 10:14:02 -05007
8inherit pypi python_poetry_core ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
Patrick Williamsb542dec2023-06-09 01:26:37 -050014RDEPENDS:${PN} += " \
15 python3-datetime \
16 python3-profile \
17 python3-stringold \
18"
19
Andrew Geissler3eeda902023-05-19 10:14:02 -050020RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-poetry-core \
22 ${PYTHON_PN}-pytest \
23 ${PYTHON_PN}-pyyaml \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}