blob: 8b86f824303f4d0b3acc1e2c73a6e9d0e75b6c5b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \
2the Linux kernel. It is a lightweight alternative to libasound."
3HOMEPAGE = "https://github.com/tinyalsa/tinyalsa"
4SECTION = "libs/multimedia"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b"
8
Brad Bishop00ab2372019-10-14 11:06:18 -04009SRCREV = "8449529c7e50f432091539ba7b438e79b04059b5"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010SRC_URI = "git://github.com/tinyalsa/tinyalsa"
11PV = "1.1.1+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17# tinyalsa is built as a static library. Enable PIC to avoid relocation
18# errors like these:
19#
20# unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `stderr@@GLIBC_2.17'
21CFLAGS += " -fPIC -DPIC "