blob: 31503e9c620a7bf6f5bf090ed4b036d545571de2 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Console mouse driver"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
3for the console and xterm, with sample clients included \
4(emacs, etc)."
Brad Bishopc342db32019-05-15 21:57:59 -04005HOMEPAGE = "https://www.nico.schottelius.org/software/gpm"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006SECTION = "console/utils"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-or-later"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
9
10PV = "1.99.7+git${SRCREV}"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050011SRCREV = "e82d1a653ca94aa4ed12441424da6ce780b1e530"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013DEPENDS = "ncurses bison-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI = "git://github.com/telmich/gpm;protocol=https;branch=master \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016 file://init \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017 file://gpm.service.in \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019
20S = "${WORKDIR}/git"
21
Andrew Geissler82c905d2020-04-13 13:39:40 -050022inherit autotools-brokensep update-rc.d systemd texinfo
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023
24INITSCRIPT_NAME = "gpm"
25INITSCRIPT_PARAMS = "defaults"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027do_configure:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028 (cd ${S};./autogen.sh;cd -)
29}
30
Patrick Williams213cb262021-08-07 19:21:33 -050031do_install:append () {
Brad Bishopc342db32019-05-15 21:57:59 -040032 install -d ${D}${systemd_system_unitdir}
33 sed 's:@bindir@:${sbindir}:' < ${WORKDIR}/gpm.service.in >${D}${systemd_system_unitdir}/gpm.service
34 install -D -m 0755 ${WORKDIR}/init ${D}${INIT_D_DIR}/gpm
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035 ln -s libgpm.so.2 ${D}${libdir}/libgpm.so
36}
37
Patrick Williams213cb262021-08-07 19:21:33 -050038SYSTEMD_SERVICE:${PN} = "gpm.service"