blob: 88a6e5bb3068a0b6e7bf9726c4305f021132095e [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Intel(R) Enclosure LED Utilities"
2
3DESCRIPTION = "The utilities are designed primarily to be used on storage servers \
4 utilizing MD devices (aka Linux Software RAID) for RAID arrays.\
5"
6HOMEPAGE = "https://github.com/intel/ledmon"
7
8LICENSE = "LGPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11DEPENDS = "sg3-utils udev pciutils"
12
13inherit autotools systemd pkgconfig
14
15SYSTEMD_SERVICE:${PN} = "ledmon.service"
16
17SRC_URI = "git://github.com/intel/ledmon;branch=master;protocol=https \
18 file://0002-include-sys-select.h-and-sys-types.h.patch \
19 file://0001-fix-build-with-clang.patch"
20
21SRCREV = "b0edae14e8660b80ffe0384354038a9f62e2978d"
22
23COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
24COMPATIBLE_HOST:libc-musl = "null"
25
26S = "${WORKDIR}/git"
27
28EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd', '', d)}"
29
30EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
31
32# The ledmon sources include headers in ${S}/config to build but not in CFLAGS.
33# We need to add this include path in CFLAGS.
34CFLAGS += "-I${S}/config"