Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Intel(R) Enclosure LED Utilities" |
| 2 | |
| 3 | DESCRIPTION = "The utilities are designed primarily to be used on storage servers \ |
| 4 | utilizing MD devices (aka Linux Software RAID) for RAID arrays.\ |
| 5 | " |
| 6 | HOMEPAGE = "https://github.com/intel/ledmon" |
| 7 | |
| 8 | LICENSE = "LGPL-2.0-only" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 10 | |
| 11 | DEPENDS = "sg3-utils udev pciutils" |
| 12 | |
| 13 | inherit autotools systemd pkgconfig |
| 14 | |
| 15 | SYSTEMD_SERVICE:${PN} = "ledmon.service" |
| 16 | |
| 17 | SRC_URI = "git://github.com/intel/ledmon;branch=master;protocol=https \ |
| 18 | file://0002-include-sys-select.h-and-sys-types.h.patch \ |
| 19 | file://0001-fix-build-with-clang.patch" |
| 20 | |
| 21 | SRCREV = "b0edae14e8660b80ffe0384354038a9f62e2978d" |
| 22 | |
| 23 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 24 | COMPATIBLE_HOST:libc-musl = "null" |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd', '', d)}" |
| 29 | |
| 30 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" |
| 31 | |
| 32 | # The ledmon sources include headers in ${S}/config to build but not in CFLAGS. |
| 33 | # We need to add this include path in CFLAGS. |
| 34 | CFLAGS += "-I${S}/config" |