Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "Doing dirty (but extremely useful) things with equals." |
| 2 | DESCRIPTION = "dirty-equals is a python library that (mis)uses the \ |
| 3 | __eq__ method to make python code (generally unit tests) more \ |
| 4 | declarative and therefore easier to read and write.\ |
| 5 | \ |
| 6 | dirty-equals can be used in whatever context you like, but it comes \ |
| 7 | into its own when writing unit tests for applications where you're \ |
| 8 | commonly checking the response to API calls and the contents of a database." |
| 9 | HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals" |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "a580513f3285e93656a770a04e428f8bfc513848877bf278282dbfbb907fdbb4" |
| 14 | |
| 15 | S = "${WORKDIR}/dirty_equals-${PV}" |
| 16 | |
| 17 | inherit pypi python_hatchling |
| 18 | |
| 19 | PYPI_PACKAGE = "dirty_equals" |
| 20 | |
| 21 | RDEPENDS:${PN} += "python3-pytz" |