blob: 35011553c238080bf8318005524a9ccfd4fa1f23 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Python SQL toolkit and Object Relational Mapper that gives \
2application developers the full power and flexibility of SQL"
3HOMEPAGE = "http://www.sqlalchemy.org/"
4LICENSE = "MIT"
Patrick Williams705982a2024-01-12 09:51:57 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=c78b979ae6c20775a28a287d32092cbb"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06006
Patrick Williams705982a2024-01-12 09:51:57 -06007SRC_URI[sha256sum] = "a2c69a7664fb2d54b8682dd774c3b54f67f84fa123cf84dda2a5f40dcaa04e08"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008
9PYPI_PACKAGE = "SQLAlchemy"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 python3-asyncio \
14 python3-compression \
15 python3-json \
16 python3-logging \
17 python3-netclient \
18 python3-numbers \
19 python3-pickle \
20 python3-profile \
21 python3-threading \
22 python3-typing-extensions \
23"
24
25BBCLASSEXTEND = "native nativesdk"