Brad Bishop | 69eac0b | 2020-08-10 18:13:26 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Image with Phosphor, a software stack for hardware management \ |
| 2 | in devices with baseboard management controllers. The image supports the \ |
| 3 | full OpenBMC feature set for devices of all types." |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | inherit obmc-phosphor-image |
| 7 | |
| 8 | # The /etc/version file is misleading and not useful. Remove it. |
| 9 | # Users should instead rely on /etc/os-release. |
| 10 | ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; " |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 11 | |
Brad Bishop | 0c434cc | 2018-12-05 07:03:22 -0500 | [diff] [blame] | 12 | IMAGE_LINGUAS = "" |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 13 | IMAGE_FEATURES += " \ |
| 14 | obmc-bmc-state-mgmt \ |
Brad Bishop | b52116a | 2020-08-10 20:45:15 -0400 | [diff] [blame] | 15 | obmc-bmcweb \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 16 | obmc-chassis-mgmt \ |
| 17 | obmc-chassis-state-mgmt \ |
Brad Bishop | 8c09b14 | 2020-08-11 08:20:31 -0400 | [diff] [blame] | 18 | obmc-console \ |
Brad Bishop | e3fe578 | 2020-08-10 20:20:47 -0400 | [diff] [blame] | 19 | obmc-devtools \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 20 | obmc-fan-control \ |
| 21 | obmc-fan-mgmt \ |
| 22 | obmc-flash-mgmt \ |
Brad Bishop | c1371fd | 2020-08-18 19:30:11 -0400 | [diff] [blame] | 23 | obmc-fru-ipmi \ |
Vijay Khemka | d549dee | 2020-09-08 11:56:19 -0700 | [diff] [blame] | 24 | obmc-health-monitor \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 25 | obmc-host-ctl \ |
| 26 | obmc-host-ipmi \ |
| 27 | obmc-host-state-mgmt \ |
Brad Bishop | b52116a | 2020-08-10 20:45:15 -0400 | [diff] [blame] | 28 | obmc-ikvm \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 29 | obmc-inventory \ |
| 30 | obmc-leds \ |
| 31 | obmc-logging-mgmt \ |
| 32 | obmc-remote-logging-mgmt \ |
Brad Bishop | 8c09b14 | 2020-08-11 08:20:31 -0400 | [diff] [blame] | 33 | obmc-rng \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 34 | obmc-net-ipmi \ |
| 35 | obmc-sensors \ |
| 36 | obmc-software \ |
Patrick Williams | 5a5f33c | 2021-11-03 10:35:37 -0500 | [diff] [blame] | 37 | obmc-system-mgmt \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 38 | obmc-user-mgmt \ |
Brad Bishop | b52116a | 2020-08-10 20:45:15 -0400 | [diff] [blame] | 39 | obmc-user-mgmt-ldap \ |
Brad Bishop | 3c2460a | 2020-08-10 19:26:43 -0400 | [diff] [blame] | 40 | ${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', 'read-only-rootfs', '', d)} \ |
| 41 | ${@bb.utils.contains('DISTRO_FEATURES', 'phosphor-mmc', 'read-only-rootfs', '', d)} \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 42 | ssh-server-dropbear \ |
| 43 | obmc-debug-collector \ |
| 44 | obmc-network-mgmt \ |
| 45 | obmc-settings-mgmt \ |
Wludzik, Jozef | e9defc0 | 2021-01-28 09:36:34 +0100 | [diff] [blame] | 46 | obmc-telemetry \ |
Brad Bishop | 3132c98 | 2020-08-10 19:18:57 -0400 | [diff] [blame] | 47 | " |
Brad Bishop | 4041ba5 | 2020-08-10 19:58:36 -0400 | [diff] [blame] | 48 | # The shadow recipe provides the binaries(like useradd, usermod) needed by the |
| 49 | # phosphor-user-manager. |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 50 | ROOTFS_RO_UNNEEDED:remove = "shadow" |