Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 1 | SUMMARY = "Timing analysis tools for suspend/resume/boot" |
| 2 | DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \ |
| 3 | in optimizing their linux stack's suspend/resume & boot time." |
| 4 | HOMEPAGE = "https://01.org/pm-graph" |
| 5 | LICENSE = "GPL-2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" |
| 7 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 8 | SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6" |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 9 | SRC_URI = "git://github.com/intel/pm-graph.git \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 10 | file://0001-Makefile-fix-multilib-build-failure.patch \ |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 11 | file://0001-sleepgraph.py-use-python3.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 12 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | COMPATIBLE_HOST='(i.86|x86_64).*' |
Brad Bishop | c8f4712 | 2019-06-24 09:36:18 -0400 | [diff] [blame] | 16 | EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 17 | |
| 18 | do_install() { |
| 19 | oe_runmake install |
| 20 | } |
| 21 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 22 | RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression" |