blob: 32afd377da338511bb23a86b0df2685fb1f335dd [file] [log] [blame]
Andrew Geisslercc589282020-09-18 13:34:40 -05001SUMMARY = "IBM's Software TPM 2.0"
2DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \
3education, and virtualization. \
4\
5The intent is that an application can be developed using the software TPM. \
6The application should then run using a hardware TPM without changes. \
7Advantages of this approach: \
8* In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \
9* Application software errors are easily reversed by simply removing the TPM state and starting over. \
10* Difficult crypto errors are quickly debugged by looking inside the TPM."
11HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html"
12LICENSE = "BSD"
13SECTION = "securty/tpm"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f"
15
16DEPENDS = "openssl"
17
18SRC_URI = "https://sourceforge.net/projects/ibmswtpm2/files/ibmtpm${PV}.tar.gz \
19 file://tune-makefile.patch \
20 file://fix-wrong-cast.patch \
21 "
22SRC_URI[md5sum] = "43b217d87056e9155633925eb6ef749c"
23SRC_URI[sha256sum] = "dd3a4c3f7724243bc9ebcd5c39bbf87b82c696d1c1241cb8e5883534f6e2e327"
24SRC_URI[sha1sum] = "ab4b94079e57a86996991e8a2b749ce063e4ad3e"
25SRC_URI[sha384sum] = "bbef16a934853ce78cba7ddc766aa9d7ef3cde3430a322b1be772bf3ad4bd6d413ae9c4de21bc1a4879d17dfe2aadc1d"
26SRC_URI[sha512sum] = "007aa415cccf19a2bcf789c426727dc4032dcb04cc9d11eedc231d2add708c1134d3d5ee5cfbe7de68307c95fff7a30bd306fbd8d53c198a5ef348440440a6ed"
27
28S = "${WORKDIR}/src"
29
30CFLAGS += "-Wno-error=maybe-uninitialized"
31
32do_compile () {
33 make CC='${CC}'
34}
35
36do_install () {
37 install -d ${D}/${bindir}
38 install -m 0755 tpm_server ${D}/${bindir}
39}