blob: 9e820d0dbfe6e83038a0240d36138e4242f29c4c [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001# SPDX-FileCopyrightText: Huawei Inc.
2# SPDX-License-Identifier: MIT
3
Andrew Geissler3eeda902023-05-19 10:14:02 -05004SRC_URI = "git://git.ostc-eu.org/rzr/dialog-lvgl;destsuffix=${S};protocol=https;nobranch=1 \
5 file://0001-wayland-Switch-to-custom-timer-tick.patch \
6 file://0002-wayland-Fix-callback-data-type.patch \
7 "
8SRCREV = "cdf8d38acca87e871c3a488fd07f1e4779590f8e"
Andrew Geissler87f5cff2022-09-30 13:13:31 -05009
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=8ce0a84e5276f01364119c873b712c4f"
12AUTHOR = "Philippe Coval <philippe.coval.ext@huawei.com>"
13
14DEPENDS += "lvgl"
15DEPENDS += "lv-drivers"
16
17SUMMARY = "Basic UI utility to be used in scripts"
18DESCRIPTION = "Inspired by ncurses' dialog, implemented using LVGL"
19HOMEPAGE = "https://git.ostc-eu.org/rzr/dialog-lvgl/-/wikis/"
20
21REQUIRED_DISTRO_FEATURES = "wayland"
22
23inherit pkgconfig
24inherit features_check
25
26EXTRA_OEMAKE += "sysroot=${RECIPE_SYSROOT}"
27EXTRA_OEMAKE += "DESTDIR=${D}"
28EXTRA_OEMAKE += "lvgl_driver=wayland"
29
30do_install() {
31 oe_runmake install
32}