Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: Huawei Inc. |
| 2 | # SPDX-License-Identifier: MIT |
| 3 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame^] | 4 | SRC_URI = "git://git.ostc-eu.org/rzr/dialog-lvgl;destsuffix=${S};protocol=https;nobranch=1 \ |
| 5 | file://0001-wayland-Switch-to-custom-timer-tick.patch \ |
| 6 | file://0002-wayland-Fix-callback-data-type.patch \ |
| 7 | " |
| 8 | SRCREV = "cdf8d38acca87e871c3a488fd07f1e4779590f8e" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8ce0a84e5276f01364119c873b712c4f" |
| 12 | AUTHOR = "Philippe Coval <philippe.coval.ext@huawei.com>" |
| 13 | |
| 14 | DEPENDS += "lvgl" |
| 15 | DEPENDS += "lv-drivers" |
| 16 | |
| 17 | SUMMARY = "Basic UI utility to be used in scripts" |
| 18 | DESCRIPTION = "Inspired by ncurses' dialog, implemented using LVGL" |
| 19 | HOMEPAGE = "https://git.ostc-eu.org/rzr/dialog-lvgl/-/wikis/" |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = "wayland" |
| 22 | |
| 23 | inherit pkgconfig |
| 24 | inherit features_check |
| 25 | |
| 26 | EXTRA_OEMAKE += "sysroot=${RECIPE_SYSROOT}" |
| 27 | EXTRA_OEMAKE += "DESTDIR=${D}" |
| 28 | EXTRA_OEMAKE += "lvgl_driver=wayland" |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake install |
| 32 | } |