blob: e1e335869549360a12506d777bdb05b7be88a930 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "JSON Web Token implementation in Python"
2DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
3 Original implementation was written by https://github.com/progrium"
4HOMEPAGE = "http://github.com/jpadilla/pyjwt"
5LICENSE = "MIT"
Andrew Geissler78b72792022-06-14 06:47:25 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551"
Andrew Geisslereff27472021-10-29 15:35:00 -05007
Andrew Geissler3eeda902023-05-19 10:14:02 -05008SRC_URI[sha256sum] = "bd6ca4a3c4285c1a2d4349e5a035fdf8fb94e04ccd0fcbe6ba289dae9cc3e074"
Andrew Geisslereff27472021-10-29 15:35:00 -05009
10PYPI_PACKAGE = "PyJWT"
11inherit pypi setuptools3
12
13RDEPENDS:${PN} = "${PYTHON_PN}-cryptography"
14
15BBCLASSEXTEND = "native nativesdk"