blob: 96fce2e048b4d1a4630adb4ff28d28ef45eb76f7 [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
5
6SRC_URI += " \
7 git://github.com/pylint-dev/pylint;branch=main;protocol=https \
8 file://run-ptest \
9 file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \
10 file://0001-pylint-remove-plugin-pickle-test.patch \
11 "
12SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85"
13
14inherit python_setuptools_build_meta ptest
15
16RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
17 ${PYTHON_PN}-dill \
18 ${PYTHON_PN}-isort \
19 ${PYTHON_PN}-mccabe \
20 ${PYTHON_PN}-numbers \
21 ${PYTHON_PN}-platformdirs \
22 ${PYTHON_PN}-shell \
23 ${PYTHON_PN}-json \
24 ${PYTHON_PN}-pkgutil \
25 ${PYTHON_PN}-difflib \
26 ${PYTHON_PN}-netserver \
27 ${PYTHON_PN}-tomlkit \
28 "
29
30RDEPENDS:${PN}-ptest += " \
31 ${PYTHON_PN}-core \
32 ${PYTHON_PN}-git \
33 ${PYTHON_PN}-py \
34 ${PYTHON_PN}-pytest \
35 ${PYTHON_PN}-pytest-benchmark \
36 ${PYTHON_PN}-pytest-runner \
37 ${PYTHON_PN}-pytest-timeout \
38 ${PYTHON_PN}-pytest-xdist \
39 ${PYTHON_PN}-requests \
40 ${PYTHON_PN}-statistics \
41 ${PYTHON_PN}-tomllib \
42 ${PYTHON_PN}-typing-extensions \
43 "
44
45S = "${WORKDIR}/git"
46
47do_install_ptest() {
48 install -d ${D}${PTEST_PATH}/tests
49 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
50 sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
51}