blob: f132d91a6944088e0ecbaea80c1750237cbda1d4 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001DESCRIPTION = "Pyzstd module provides classes and functions for compressing and \
2decompressing data, using Facebook’s Zstandard (or zstd as short name) algorithm."
3HOMEPAGE = "https://github.com/animalize/pyzstd"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=8458383225d7107f3383ee5c521628d2"
8
9PYPI_PACKAGE = "pyzstd"
10
11SRC_URI[sha256sum] = "55e503f28f5a9d225ce9d0639e3f5b1801bacace5aea926ec2998e73c5150fe7"
12
13inherit pypi setuptools3
Andrew Geissler3eeda902023-05-19 10:14:02 -050014
15# clang-16 with -flto segfaults on arm, therefore ignore flto for now
16do_configure:append:arm:toolchain-clang() {
17 sed -i -e "s|'-flto'|''|" ${S}/setup.py
18}