Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Pyzstd module provides classes and functions for compressing and \ |
| 2 | decompressing data, using Facebookâs Zstandard (or zstd as short name) algorithm." |
| 3 | HOMEPAGE = "https://github.com/animalize/pyzstd" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8458383225d7107f3383ee5c521628d2" |
| 8 | |
| 9 | PYPI_PACKAGE = "pyzstd" |
| 10 | |
| 11 | SRC_URI[sha256sum] = "55e503f28f5a9d225ce9d0639e3f5b1801bacace5aea926ec2998e73c5150fe7" |
| 12 | |
| 13 | inherit pypi setuptools3 |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame^] | 14 | |
| 15 | # clang-16 with -flto segfaults on arm, therefore ignore flto for now |
| 16 | do_configure:append:arm:toolchain-clang() { |
| 17 | sed -i -e "s|'-flto'|''|" ${S}/setup.py |
| 18 | } |