Stanley Chu | c28310e | 2020-06-18 14:04:42 +0800 | [diff] [blame] | 1 | SUMMARY = "Power Cycle by Hotswap Controller" |
| 2 | DESCRIPTION = "Power Cycle by Hotswap Controller Daemon" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
David Wang | 026925d | 2021-08-13 11:39:20 +0800 | [diff] [blame] | 10 | RDEPENDS:${PN} += "bash" |
Stanley Chu | c28310e | 2020-06-18 14:04:42 +0800 | [diff] [blame] | 11 | |
| 12 | SRC_URI = " file://hotswap-power-cycle.service" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${systemd_system_unitdir} |
| 16 | install -m 0644 ${WORKDIR}/hotswap-power-cycle.service ${D}${systemd_system_unitdir} |
| 17 | } |
| 18 | |
| 19 | SYSTEMD_PACKAGES = "${PN}" |
David Wang | 026925d | 2021-08-13 11:39:20 +0800 | [diff] [blame] | 20 | SYSTEMD_SERVICE:${PN} = "hotswap-power-cycle.service" |
Stanley Chu | c28310e | 2020-06-18 14:04:42 +0800 | [diff] [blame] | 21 | |