Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Linux Kernel Runtime Guard" |
| 2 | DESCRIPTION="LKRG performs runtime integrity checking of the Linux \ |
| 3 | kernel and detection of security vulnerability exploits against the kernel." |
| 4 | SECTION = "security" |
| 5 | HOMEPAGE = "https://www.openwall.com/lkrg/" |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 6 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 7 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3f3e5dd56319d33a1944d635c1c86c6f" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 9 | |
| 10 | DEPENDS = "virtual/kernel elfutils" |
| 11 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 12 | SRC_URI = "git://github.com/lkrg-org/lkrg.git;protocol=https;branch=main" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 13 | |
Andrew Geissler | 2daf84b | 2023-03-31 09:57:23 -0500 | [diff] [blame] | 14 | SRCREV = "2481b3e2dd04eac945c31f99058b0aeee73c3a71" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 15 | |
Patrick Williams | de0582f | 2022-04-08 10:23:27 -0500 | [diff] [blame] | 16 | S = "${WORKDIR}/git" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 17 | |
| 18 | inherit module kernel-module-split |
| 19 | |
| 20 | MAKE_TARGETS = "modules" |
| 21 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 22 | MODULE_NAME = "lkrg" |
| 23 | |
| 24 | do_configure:append () { |
| 25 | sed -i -e 's/^all/modules/' ${S}/Makefile |
| 26 | sed -i -e 's/^install/modules_install/' ${S}/Makefile |
| 27 | sed -i -e 's/KERNEL/KERNEL_SRC/g' ${S}/Makefile |
| 28 | } |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 29 | |
| 30 | module_do_install() { |
| 31 | install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME} |
| 32 | install -m 0644 ${MODULE_NAME}.ko \ |
| 33 | ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko |
| 34 | } |
| 35 | |
| 36 | RPROVIDES:${PN} += "kernel-module-lkrg" |
| 37 | |
| 38 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |