Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux security scanner" |
| 2 | DESCRIPTION = "Buck-Security is a security scanner for Debian and Ubuntu Linux. It runs a couple of important checks and helps you to harden your Linux \ |
| 3 | system. This enables you to quickly overview the security status of your Linux system." |
| 4 | SECTION = "security" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 8b13928 | 2021-03-05 15:22:30 -0600 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" |
Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "http://sourceforge.net/projects/buck-security/files/buck-security/buck-security_${PV}/${BPN}_${PV}.tar.gz" |
| 9 | |
| 10 | SRC_URI[md5sum] = "611a3e9bb7ed8a8270aa15216c321c53" |
| 11 | SRC_URI[sha256sum] = "c533c6631ec3554dd8d39d2d1c3ed44badbbf50810ebb75469c74639fa294b01" |
| 12 | |
| 13 | S = "${WORKDIR}/${BPN}_${PV}" |
| 14 | |
| 15 | do_configure[noexec] = "1" |
| 16 | do_compile[noexec] = "1" |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}${bindir}/buck |
| 20 | cp -r ${S}/* ${D}${bindir}/buck |
| 21 | cp -r ${S}/buck-security ${D}${bindir} |
| 22 | sed -i 's!use lib "checks"!use lib File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck/checks")!' ${D}${bindir}/buck-security |
| 23 | sed -i 's!use lib "checks/lib"!use lib File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck/checks/lib")!' ${D}${bindir}/buck-security |
| 24 | sed -i 's!use lib "lib"!use lib File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck/lib")!' ${D}${bindir}/buck-security |
| 25 | sed -i 's!my $buck_root = "."!my $buck_root = File::Spec->catfile(dirname(File::Spec->rel2abs(__FILE__)), "buck")!' ${D}${bindir}/buck-security |
| 26 | |
| 27 | } |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | FILES:${PN} = "${bindir}/*" |
Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | RDEPENDS:${PN} = "coreutils gnupg net-tools perl perl-module-data-dumper \ |
Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 32 | perl-module-file-basename perl-module-file-spec perl-module-getopt-long \ |
| 33 | perl-module-lib perl-module-posix perl-module-term-ansicolor \ |
| 34 | perl-module-time-localtime pinentry perl-module-pod-usage \ |
| 35 | perl-module-pod-text perl-module-file-glob \ |
| 36 | " |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | RDEPENDS:${PN}:class-native = "coreutils net-tools perl perl-module-data-dumper \ |
Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 39 | perl-module-file-basename perl-module-file-spec perl-module-getopt-long \ |
| 40 | perl-module-lib perl-module-posix perl-module-term-ansicolor \ |
| 41 | perl-module-time-localtime perl-module-file-glob\ |
| 42 | " |
| 43 | |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |