Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 1 | SUMMARY = "Destined to fail" |
| 2 | LICENSE = "CLOSED" |
| 3 | |
| 4 | deltask do_patch |
| 5 | INHIBIT_DEFAULT_DEPS = "1" |
| 6 | |
| 7 | do_shelltest() { |
| 8 | echo "This is shell stdout" |
| 9 | echo "This is shell stderr" >&2 |
| 10 | exit 1 |
| 11 | } |
| 12 | addtask do_shelltest |
| 13 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 14 | python do_pythontest_exec_func_shell() { |
| 15 | bb.build.exec_func('do_shelltest', d) |
| 16 | } |
| 17 | addtask do_pythontest_exec_func_shell |
| 18 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 19 | python do_pythontest_exit () { |
| 20 | print("This is python stdout") |
| 21 | sys.exit(1) |
| 22 | } |
| 23 | addtask do_pythontest_exit |
| 24 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 25 | python do_pythontest_exec_func_python() { |
| 26 | bb.build.exec_func('do_pythontest_exit', d) |
| 27 | } |
| 28 | addtask do_pythontest_exec_func_python |
| 29 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 30 | python do_pythontest_fatal () { |
| 31 | print("This is python fatal test stdout") |
| 32 | bb.fatal("This is a fatal error") |
| 33 | } |
| 34 | addtask do_pythontest_fatal |