blob: 82cfa3b8efcb97cd85d92894f9981d155212d96d [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "An unobtrusive argparse wrapper with natural syntax"
2DESCRIPTION = "Building a command-line interface? Found yourself uttering \
3'argh!' while struggling with the API of argparse? Don't like the complexity \
4but need the power? \
5\
6Everything should be made as simple as possible, but no simpler. \
7\
8—Albert Einstein (probably) \
9\
10Argh is a smart wrapper for argparse. Argparse is a very powerful \
11tool; Argh just makes it easy to use."
12
13LICENSE = "LGPL-3.0-or-later"
14LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=3000208d539ec061b899bce1d9ce9404 \
15 file://README.rst;beginline=261;endline=275;md5=39ec83a704aed9f33618c5d04e478a08 \
16 "
17
18SRC_URI[sha256sum] = "9fca8e69c4dad4f8d2a7bdfbdd80b0754462b53510a03e1b5cf2b43a87e6e960"
19
20inherit pypi python_flit_core
21
22RDEPENDS:${PN} += " \
23 python3-argcomplete \
24 python3-logging \
25"
26
27BBCLASSEXTEND = "native nativesdk"