Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 4 | SUMMARY = "An aspect-oriented programming, monkey-patch and decorators library." |
| 5 | DESCRIPTION = " It is useful when changing behavior in existing code is desired. \ |
| 6 | It includes tools for debugging and testing: simple mock/record and a complete capture/replay framework." |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 7 | HOMEPAGE = "https://github.com/ionelmc/python-aspectlib" |
| 8 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=80721ace117fd1f814049ecb81c6be76" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 10 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "a4b461b9da0b531aebcb93efcde3de808a72c60226dd8d902c467d13faf7ce92" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 12 | |
| 13 | inherit ptest pypi setuptools3 |
| 14 | |
| 15 | SRC_URI += "file://run-ptest \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | do_install_ptest() { |
| 19 | install -d ${D}${PTEST_PATH}/tests |
| 20 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 21 | } |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | RDEPENDS:${PN}-ptest += "\ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 24 | python3-process-tests \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 25 | python3-pytest \ |
| 26 | python3-tornado \ |
| 27 | python3-unittest-automake-output \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 28 | " |
| 29 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 30 | RDEPENDS:${PN} += " \ |
| 31 | python3-fields \ |
| 32 | python3-logging \ |
| 33 | " |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |