Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "WSGI server implemented in Rust." |
| 2 | DESCRIPTION = "Pyruvate is a reasonably fast, multithreaded, non-blocking \ |
| 3 | WSGI server implemented in Rust." |
| 4 | HOMEPAGE = "https://gitlab.com/tschorr/pyruvate" |
| 5 | BUGTRACKER = "https://gitlab.com/tschorr/pyruvate/-/issues" |
| 6 | |
| 7 | LICENSE = "GPL-2.0-only" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 10 | SRC_URI += "\ |
| 11 | git://gitlab.com/tschorr/pyruvate.git;protocol=https;branch=main \ |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 12 | file://0001-linux.rs-Define-consts-for-rv32-architecture.patch;patchdir=../cargo_home/bitbake/nix-0.23.2/ \ |
| 13 | file://0001-musl-Define-SOCK_NONBLOCK-with-O_NONBLOCK.patch;patchdir=../cargo_home/bitbake/libc-0.2.138/ \ |
| 14 | file://0001-musl-riscv32-Define-F_SETLK-F_SETLKW-and-fix-F_GETLK.patch;patchdir=../cargo_home/bitbake/libc-0.2.138/ \ |
| 15 | file://0001-musl-Move-F_OFD_GETLK-F_OFD_SETLK-and-F_OFD_SETLKW-t.patch;patchdir=../cargo_home/bitbake/libc-0.2.138/ \ |
| 16 | file://0001-musl-Define-O_LARGEFILE-for-riscv32.patch;patchdir=../cargo_home/bitbake/libc-0.2.138/ \ |
| 17 | file://0001-musl-Define-SOCK_SEQPACKET-in-common-place.patch;patchdir=../cargo_home/bitbake/libc-0.2.138/ \ |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 18 | " |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 19 | SRCREV = "57db64c9f65ced05c71b8d786c1cedfaa2991597" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 21 | SRC_URI:append:mips = " file://0001-check-for-mips-targets-for-stat.st_dev-definitions.patch;patchdir=../cargo_home/bitbake/libsystemd-0.5.0/" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 22 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit python_setuptools3_rust cargo-update-recipe-crates |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 26 | |
| 27 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 28 | |
| 29 | # crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64 |
| 30 | # not supported on mips/powerpc with 32-bit pointers |
| 31 | # https://doc.rust-lang.org/std/sync/atomic/#portability |
| 32 | RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64" |
| 33 | RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64" |
| 34 | RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64" |
| 35 | RUSTFLAGS:append:riscv32 = " --cfg crossbeam_no_atomic_64" |
| 36 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 37 | require ${BPN}-crates.inc |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 38 | |
| 39 | # The following configs & dependencies are from setuptools extras_require. |
| 40 | # These dependencies are optional, hence can be controlled via PACKAGECONFIG. |
| 41 | # The upstream names may not correspond exactly to bitbake package names. |
| 42 | # |
| 43 | # Uncomment this line to enable all the optional features. |
| 44 | #PACKAGECONFIG ?= "test" |
| 45 | PACKAGECONFIG[test] = ",,,python3-pytest python3-requests" |
| 46 | |
| 47 | # WARNING: the following rdepends are determined through basic analysis of the |
| 48 | # python sources, and might not be 100% accurate. |
| 49 | RDEPENDS:${PN} += "python3-core" |