Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "RAR archive reader for Python" |
| 2 | HOMEPAGE = "https://github.com/markokr/rarfile" |
| 3 | LICENSE = "ISC" |
| 4 | SECTION = "devel/python" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2f31e224cbf0c29cb6c55f2bae0e165f" |
| 6 | |
| 7 | inherit setuptools3 |
| 8 | |
| 9 | SRC_URI[sha256sum] = "db60b3b5bc1c4bdeb941427d50b606d51df677353385255583847639473eda48" |
| 10 | |
| 11 | inherit pypi |
| 12 | |
| 13 | PYPI_PACKAGE="rarfile" |
| 14 | |
| 15 | RDEPENDS:${PN} += "\ |
| 16 | p7zip \ |
| 17 | ${PYTHON_PN}-core \ |
| 18 | ${PYTHON_PN}-datetime \ |
| 19 | ${PYTHON_PN}-crypt \ |
| 20 | ${PYTHON_PN}-io \ |
| 21 | " |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |