blob: fb011cb71b6fb64661d477fed354c75f32ce1a3c [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Python3 interface to the wxWidgets Cross-platform C++ GUI toolkit."
2HOMEPAGE = "http://www.wxpython.org"
3
4LICENSE = "LGPL-2.0-only & WXwindows"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bdabf9e11191e2b9d3b6aef5f338ec00"
6
7DEPENDS = "python3-attrdict3-native python3-six-native wxwidgets-native \
8 wxwidgets \
9 "
10
11PYPI_PACKAGE = "wxPython"
12
13SRC_URI += "file://add-back-option-build-base.patch \
14 file://wxgtk-fixup-build-scripts.patch \
15 file://not-overwrite-cflags-cxxflags.patch \
16 file://0001-sip-Conditionally-use-GetAssertStackTrace-under-USE_.patch \
17 "
18SRC_URI[sha256sum] = "e48de211a6606bf072ec3fa778771d6b746c00b7f4b970eb58728ddf56d13d5c"
19
20S = "${WORKDIR}/wxPython-${PV}"
21
22inherit pypi setuptools3 pkgconfig features_check
23
24REQUIRED_DISTRO_FEATURES = "x11"
25
26export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR} --baselib=${baselib}'"
27
28RDEPENDS:${PN} = "\
29 python3-difflib \
30 python3-image \
31 python3-numpy \
32 python3-pillow \
33 python3-pip \
34 python3-pprint \
35 python3-pycairo \
36 python3-six \
37 python3-xml \
38"