Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Python3 interface to the wxWidgets Cross-platform C++ GUI toolkit." |
| 2 | HOMEPAGE = "http://www.wxpython.org" |
| 3 | |
| 4 | LICENSE = "LGPL-2.0-only & WXwindows" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=bdabf9e11191e2b9d3b6aef5f338ec00" |
| 6 | |
| 7 | DEPENDS = "python3-attrdict3-native python3-six-native wxwidgets-native \ |
| 8 | wxwidgets \ |
| 9 | " |
| 10 | |
| 11 | PYPI_PACKAGE = "wxPython" |
| 12 | |
| 13 | SRC_URI += "file://add-back-option-build-base.patch \ |
| 14 | file://wxgtk-fixup-build-scripts.patch \ |
| 15 | file://not-overwrite-cflags-cxxflags.patch \ |
| 16 | file://0001-sip-Conditionally-use-GetAssertStackTrace-under-USE_.patch \ |
| 17 | " |
| 18 | SRC_URI[sha256sum] = "e48de211a6606bf072ec3fa778771d6b746c00b7f4b970eb58728ddf56d13d5c" |
| 19 | |
| 20 | S = "${WORKDIR}/wxPython-${PV}" |
| 21 | |
| 22 | inherit pypi setuptools3 pkgconfig features_check |
| 23 | |
| 24 | REQUIRED_DISTRO_FEATURES = "x11" |
| 25 | |
| 26 | export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR} --baselib=${baselib}'" |
| 27 | |
| 28 | RDEPENDS:${PN} = "\ |
| 29 | python3-difflib \ |
| 30 | python3-image \ |
| 31 | python3-numpy \ |
| 32 | python3-pillow \ |
| 33 | python3-pip \ |
| 34 | python3-pprint \ |
| 35 | python3-pycairo \ |
| 36 | python3-six \ |
| 37 | python3-xml \ |
| 38 | " |