Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Boost.Build" |
| 2 | DESCRIPTION = "B2 makes it easy to build C++ projects, everywhere." |
| 3 | HOMEPAGE = "https://github.com/boostorg/build" |
| 4 | SECTION = "devel" |
| 5 | |
| 6 | LICENSE = "BSL-1.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 8 | |
| 9 | SRC_URI = "git://github.com/boostorg/build;protocol=https;branch=master" |
| 10 | SRCREV = "405d34a04d29519625c5edfe1f3bac3bc3dc3534" |
| 11 | PE = "1" |
| 12 | |
| 13 | UPSTREAM_CHECK_GITTAGREGEX = "boost-(?P<pver>(\d+(\.\d+)+))" |
| 14 | |
| 15 | inherit native |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | do_compile() { |
| 20 | ./bootstrap.sh |
| 21 | } |
| 22 | |
| 23 | do_install() { |
| 24 | HOME=/var/run ./b2 install --prefix=${prefix} staging-prefix=${D}${prefix} |
| 25 | } |
| 26 | |
| 27 | # The build is either release mode (pre-stripped) or debug (-O0). |
| 28 | INSANE_SKIP:${PN} = "already-stripped" |