Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 1 | SUMMARY = "LevelDB is a fast key-value storage library" |
| 2 | DESCRIPTION = "LevelDB is a fast key-value storage library that provides an ordered mapping from string keys to string values" |
| 3 | HOMEPAGE = "https://github.com/google/leveldb" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=92d1b128950b11ba8495b64938fc164d" |
| 6 | |
| 7 | SRC_URI = "git://github.com/google/${BPN}.git \ |
| 8 | file://run-ptest" |
| 9 | |
| 10 | SRCREV = "78b39d68c15ba020c0d60a3906fb66dbf1697595" |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake ptest |
| 14 | |
| 15 | PACKAGECONFIG ??= "" |
| 16 | PACKAGECONFIG[benchmarks] = "-DLEVELDB_BUILD_BENCHMARKS=ON,-DLEVELDB_BUILD_BENCHMARKS=OFF,sqlite" |
| 17 | PACKAGECONFIG[snappy] = ",,snappy" |
| 18 | PACKAGECONFIG[tcmalloc] = ",,gperftools" |
| 19 | |
| 20 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=RelWithDebInfo -DBUILD_SHARED_LIBS=ON -DCMAKE_SKIP_RPATH=ON \ |
| 21 | -DLEVELDB_BUILD_TESTS=${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'ON', 'OFF', d)}" |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | do_install:append() { |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 24 | install -D -m 0755 ${B}/leveldbutil ${D}${bindir}/leveldbutil |
| 25 | } |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | install -m 0755 ${B}/*_test ${D}${PTEST_PATH} |
| 29 | } |
| 30 | |
| 31 | # Do not try to build lib32-leveldb for mips64, but allow libn32-leveldb. |
| 32 | # |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | COMPATIBLE_HOST:mipsarcho32:pn-lib32-leveldb = "null" |