Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A simple memory benchmark program, which tries to measure the \ |
| 2 | peak bandwidth of sequential memory accesses and the latency of random memory \ |
| 3 | accesses. Bandwidth is measured by running different assembly code for the \ |
| 4 | aligned memory blocks and attempting different prefetch strategies" |
| 5 | HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345" |
| 8 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 9 | PV = "0.4.9+git${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | SRCREV = "a2cf6d7e382e3aea1eb39173174d9fa28cad15f3" |
| 12 | SRC_URI = "git://github.com/ssvb/tinymembench.git \ |
| 13 | file://0001-asm-Delete-.func-.endfunc-directives.patch \ |
| 14 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 18 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 19 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | do_install() { |
| 21 | install -d ${D}${bindir} |
| 22 | install -m755 tinymembench ${D}${bindir}/ |
| 23 | } |
| 24 | |
| 25 | # Fails to build with thumb-1 (qemuarm) |
| 26 | #| {standard input}: Assembler messages: |
| 27 | #| {standard input}:66: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16' |
| 28 | #| {standard input}:69: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16' |
| 29 | #| {standard input}:82: Error: selected processor does not support Thumb mode `mla r3,r4,r3,r5' |
| 30 | #| {standard input}:82: Error: unshifted register required -- `and r8,r7,r3,lsr#16' |
| 31 | ARM_INSTRUCTION_SET = "arm" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 32 | # |
| 33 | # Does not work for 64bit mips. |
| 34 | # |
| 35 | COMPATIBLE_HOST = "^(?!mips64).*" |