Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 1 | # Common code for dbus applications using c. |
| 2 | |
| 3 | inherit obmc-phosphor-systemd |
| 4 | inherit obmc-phosphor-license |
| 5 | |
| 6 | DEPENDS += "glib-2.0" |
Brad Bishop | 09494ec | 2015-10-18 22:21:04 -0400 | [diff] [blame] | 7 | |
| 8 | INSTALL_NAME ?= "${PN}" |
| 9 | BIN_NAME ?= "${INSTALL_NAME}" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 10 | |
| 11 | do_install_append() { |
| 12 | # install the binary |
| 13 | install -d ${D}${sbindir} |
Brad Bishop | 09494ec | 2015-10-18 22:21:04 -0400 | [diff] [blame] | 14 | install -m 0755 ${S}/${BIN_NAME} ${D}${sbindir}/${INSTALL_NAME} |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 15 | } |