Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # |
| 2 | # This class will generate the proper postinst/postrm scriptlets for font |
| 3 | # packages. |
| 4 | # |
| 5 | |
| 6 | DEPENDS += "qemu-native" |
| 7 | inherit qemu |
| 8 | |
| 9 | FONT_PACKAGES ??= "${PN}" |
| 10 | FONT_EXTRA_RDEPENDS ?= "fontconfig-utils" |
| 11 | FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig" |
| 12 | fontcache_common() { |
| 13 | if [ "x$D" != "x" ] ; then |
| 14 | $INTERCEPT_DIR/postinst_intercept update_font_cache ${PKG} mlprefix=${MLPREFIX} bindir=${bindir} \ |
| 15 | libdir=${libdir} base_libdir=${base_libdir} fontconfigcachedir=${FONTCONFIG_CACHE_DIR} |
| 16 | else |
| 17 | fc-cache |
| 18 | fi |
| 19 | } |
| 20 | |
| 21 | python () { |
| 22 | font_pkgs = d.getVar('FONT_PACKAGES', True).split() |
| 23 | deps = d.getVar("FONT_EXTRA_RDEPENDS", True) |
| 24 | |
| 25 | for pkg in font_pkgs: |
| 26 | if deps: d.appendVar('RDEPENDS_' + pkg, ' '+deps) |
| 27 | } |
| 28 | |
| 29 | python add_fontcache_postinsts() { |
| 30 | for pkg in d.getVar('FONT_PACKAGES', True).split(): |
| 31 | bb.note("adding fonts postinst and postrm scripts to %s" % pkg) |
| 32 | postinst = d.getVar('pkg_postinst_%s' % pkg, True) or d.getVar('pkg_postinst', True) |
| 33 | if not postinst: |
| 34 | postinst = '#!/bin/sh\n' |
| 35 | postinst += d.getVar('fontcache_common', True) |
| 36 | d.setVar('pkg_postinst_%s' % pkg, postinst) |
| 37 | |
| 38 | postrm = d.getVar('pkg_postrm_%s' % pkg, True) or d.getVar('pkg_postrm', True) |
| 39 | if not postrm: |
| 40 | postrm = '#!/bin/sh\n' |
| 41 | postrm += d.getVar('fontcache_common', True) |
| 42 | d.setVar('pkg_postrm_%s' % pkg, postrm) |
| 43 | } |
| 44 | |
| 45 | PACKAGEFUNCS =+ "add_fontcache_postinsts" |