Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Helper class to pull in the right gtk-doc dependencies and disable |
| 2 | # gtk-doc. |
| 3 | # |
| 4 | # Long-term it would be great if this class could be toggled between |
| 5 | # gtk-doc-stub-native and the real gtk-doc-native, which would enable |
| 6 | # re-generation of documentation. For now, we'll make do with this which |
| 7 | # packages up any existing documentation (so from tarball builds). |
| 8 | |
| 9 | # The documentation directory, where the infrastructure will be copied. |
| 10 | # gtkdocize has a default of "." so to handle out-of-tree builds set this to $S. |
| 11 | GTKDOC_DOCDIR ?= "${S}" |
| 12 | |
| 13 | DEPENDS_append = " gtk-doc-stub-native" |
| 14 | |
| 15 | EXTRA_OECONF_append = "\ |
| 16 | --disable-gtk-doc \ |
| 17 | --disable-gtk-doc-html \ |
| 18 | --disable-gtk-doc-pdf \ |
| 19 | " |
| 20 | |
| 21 | do_configure_prepend () { |
| 22 | ( cd ${S}; gtkdocize --docdir ${GTKDOC_DOCDIR} ) |
| 23 | } |
| 24 | |
| 25 | inherit pkgconfig |