Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Disk partition editing/resizing utility" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/parted/parted.html" |
| 3 | LICENSE = "GPLv3+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c" |
| 5 | SECTION = "console/tools" |
| 6 | DEPENDS = "ncurses readline util-linux" |
| 7 | PR = "r1" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \ |
| 10 | file://no_check.patch \ |
| 11 | file://syscalls.patch \ |
| 12 | file://fix-doc-mandir.patch \ |
| 13 | file://fix-compile-failure-while-dis.patch \ |
| 14 | file://0001-Include-fcntl.h-in-platform_defs.h.patch \ |
| 15 | file://0001-Unset-need_charset_alias-when-building-for-musl.patch \ |
| 16 | file://run-ptest \ |
| 17 | file://Makefile \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "0247b6a7b314f8edeb618159fa95f9cb" |
| 21 | SRC_URI[sha256sum] = "858b589c22297cacdf437f3baff6f04b333087521ab274f7ab677cb8c6bb78e4" |
| 22 | |
| 23 | EXTRA_OECONF = "--disable-device-mapper" |
| 24 | |
| 25 | inherit autotools pkgconfig gettext texinfo ptest |
| 26 | |
| 27 | BBCLASSEXTEND = "native" |
| 28 | |
| 29 | do_compile_ptest() { |
| 30 | oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize |
| 31 | } |
| 32 | |
| 33 | do_install_ptest() { |
| 34 | t=${D}${PTEST_PATH} |
| 35 | mkdir $t/build-aux |
| 36 | cp ${S}/build-aux/test-driver $t/build-aux/ |
| 37 | cp -r ${S}/tests $t |
| 38 | cp ${WORKDIR}/Makefile $t/tests/ |
| 39 | sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile |
| 40 | for i in print-align print-max dup-clobber duplicate fs-resize; \ |
| 41 | do cp ${B}/tests/.libs/$i $t/tests/; \ |
| 42 | done |
| 43 | sed -e 's| ../parted||' -i $t/tests/*.sh |
| 44 | } |
| 45 | |
| 46 | RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python" |