blob: d8708f5e72861cd609247386020b462f8d65d3fa [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)"
2LICENSE = "MIT"
Patrick Williams8e7b46e2023-05-01 14:19:06 -05003LIC_FILES_CHKSUM = "file://LICENSE;md5=873757af01d2d221eedb422c4c1dd163"
Andrew Geissler517393d2023-01-13 08:55:19 -06004DEPENDS = "python3-cython proj"
5DEPENDS:append:class-target = " python3-cython-native proj-native"
6
7PYPI_PACKAGE = "pyproj"
8
9inherit pypi setuptools3
10
Patrick Williams520786c2023-06-25 16:20:36 -050011SRC_URI[sha256sum] = "a5b111865b3f0f8b77b3983f2fbe4dd6248fc09d3730295949977c8dcd988062"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
Patrick Williamsb542dec2023-06-09 01:26:37 -050013RDEPENDS:${PN} = " \
14 python3-certifi \
15 python3-compression \
16 python3-json \
17 python3-logging \
18 python3-profile \
19"
Andrew Geissler517393d2023-01-13 08:55:19 -060020
21export PROJ_INCDIR = "${STAGING_INCDIR}"
22export PROJ_LIBDIR = "${STAGING_LIBDIR}"
23export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.."