Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "netkit-rusers includes rusers - Displays who is logged in to machines on local network \ |
| 2 | rusersd - Logged in users server" |
| 3 | HOMEPAGE = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit" |
| 4 | SECTION = "net" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | LICENSE = "BSD-3-Clause" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://rusers/rusers.c;beginline=2;endline=3;md5=f4fc634a4ce8c569911196b72b10770e" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 7 | DEPENDS = " tcp-wrappers libtirpc rpcbind rpcsvc-proto rpcsvc-proto-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Brad Bishop | 7f28bc5 | 2017-12-03 23:42:40 -0500 | [diff] [blame] | 9 | SRC_URI = "http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz;name=archive \ |
| 10 | http://http.debian.net/debian/pool/main/n/${BPN}/${BPN}_${PV}-8.diff.gz;name=patch8 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://rpc.rusersd-Makefile-fix-parallel-build-issue.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | file://0001-Link-with-libtirpc.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | " |
| 14 | |
| 15 | SRC_URI[archive.md5sum] = "dc99a80b9fde2ab427c874f88f1c1602" |
| 16 | SRC_URI[archive.sha256sum] = "f00138651865ad2dcfec5dedda0cda403cb80c4ab68efcc3bbccafe198c24b6d" |
| 17 | SRC_URI[patch8.md5sum] = "1ff498113e0f920d92088092e5570bdc" |
| 18 | SRC_URI[patch8.sha256sum] = "14882dbdda4e37baa84d55b54b46c7e063a20fc9e04d1be1a2807643cd0f3067" |
| 19 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 21 | |
| 22 | EXTRA_OEMAKE = "RUSERSX=${STAGING_INCDIR}/rpcsvc/rusers.x" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | do_configure () { |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 25 | ./configure --prefix=${prefix} --installroot=${D} --with-c-compiler="${CC}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | } |
| 27 | |
| 28 | do_install () { |
| 29 | install -d ${D}${bindir} |
| 30 | install -d ${D}${sbindir} |
| 31 | install -d ${D}${mandir}/man1 |
| 32 | install -d ${D}${mandir}/man8 |
| 33 | install -d ${D}${sysconfdir}/xinetd.d |
| 34 | |
| 35 | sed -i 's/install -s/install/' rusers/Makefile |
| 36 | sed -i 's/install -s/install/' rup/Makefile |
| 37 | sed -i 's/install -s/install/' rpc.rusersd/Makefile |
| 38 | |
| 39 | oe_runmake 'INSTALLROOT=${D}' 'BINMODE=0755' \ |
| 40 | 'DAEMONMODE=0755' 'MANMODE=0644' \ |
| 41 | 'BINDIR=${bindir}' 'SBINDIR=${sbindir}' \ |
| 42 | 'MANDIR=${mandir}' install |
| 43 | |
| 44 | # create the xinetd config file |
| 45 | cat >rusersd.conf <<EOF |
| 46 | service rusersd |
| 47 | { |
| 48 | disable = yes |
| 49 | type = RPC |
| 50 | rpc_version = 1-2 |
| 51 | socket_type = dgram |
| 52 | protocol = udp |
| 53 | wait = yes |
| 54 | user = root |
| 55 | server = ${sbindir}/rpc.rusersd |
| 56 | } |
| 57 | EOF |
| 58 | install rusersd.conf ${D}/${sysconfdir}/xinetd.d/rusersd |
| 59 | } |
| 60 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 61 | PACKAGES = "${PN}-client ${PN}-server ${PN}-doc ${BPN}-dbg" |
| 62 | FILES_${PN}-client = "${bindir}/*" |
| 63 | FILES_${PN}-server = "${sbindir}/* ${sysconfdir}" |
| 64 | FILES_${PN}-doc = "${mandir}" |
| 65 | FILES_${PN}-dbg = "${prefix}/src/debug \ |
| 66 | ${bindir}/.debug ${sbindir}/.debug" |
| 67 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 68 | RDEPENDS_${PN}-server += "tcp-wrappers xinetd rpcbind" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 69 | |
| 70 | # http://errors.yoctoproject.org/Errors/Details/186962/ |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 71 | COMPATIBLE_HOST_libc-musl = 'null' |
Andrew Geissler | eafcbb8 | 2020-06-05 17:59:17 -0500 | [diff] [blame] | 72 | PNBLACKLIST[netkit-rusers] ?= "Fails to build rup.c:51:10: fatal error: rstat.h: No such file or directory" |