Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Small collection of benchmarks for storage I/O" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b529aaa6a0c50f15d29f89609b5c22f3" |
| 4 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | SRCREV = "f97f1ae321d1fb8111a2c638075702ed2512ff07" |
| 6 | PV = "3.6" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | SRC_URI = "git://github.com/Algodev-github/S.git;protocol=https;branch=master" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | # installing in /opt/S-suite since the package has |
| 12 | # dependencies to the directory structure. |
| 13 | do_install() { |
| 14 | install -d ${D}/opt/S-suite |
| 15 | for i in $(find ${S}/* -type d); do |
| 16 | install -d ${D}/opt/S-suite/$(basename $i) |
| 17 | install -m0755 -p ${S}/$(basename $i)/* ${D}/opt/S-suite/$(basename $i) |
| 18 | done |
| 19 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | install -m0755 ${S}/def_config.sh ${D}/opt/S-suite |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | install -m0755 ${S}/config_params.sh ${D}/opt/S-suite |
Brad Bishop | 2f97392 | 2019-11-11 07:58:48 -0500 | [diff] [blame] | 22 | install -m0755 ${S}/create_config.sh ${D}/opt/S-suite |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | install -m0755 ${S}/process_config.sh ${D}/opt/S-suite |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | } |
| 25 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | RDEPENDS_${PN} = "bash bc coreutils gawk g++ gcc fio libaio libaio-dev sysstat \ |
| 27 | git" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | |
| 29 | FILES_${PN} = "/opt/S-suite/" |
| 30 | |
| 31 | # added to INSANE_SKIP since s-suite have an runtime |
| 32 | # dependency (RDEPENDS) on libaio-dev. |
| 33 | INSANE_SKIP_${PN} += "dev-deps" |