Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 1 | SUMMARY = "Linux Firmware Loader Daemon" |
| 2 | DESCRIPTION = "The Linux Firmware Loader Daemon monitors the kernel for \ |
| 3 | firmware requests and uploads the firmware blobs it has via the sysfs \ |
| 4 | interface." |
| 5 | HOMEPAGE = "https://github.com/teg/firmwared" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE-APACHE;md5=7b486c2338d225a1405d979ed2c15ce8 \ |
| 8 | file://COPYING;md5=daa868b8e1ae17d03228a1145b4060da" |
| 9 | |
| 10 | SRC_URI = "git://github.com/teg/firmwared.git \ |
| 11 | file://firmwared.service" |
| 12 | |
| 13 | PV = "0+git${SRCPV}" |
| 14 | SRCREV = "2e6b5db43d63a5c0283a4cae9a6a20b7ad107a04" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | DEPENDS = "glib-2.0 systemd" |
| 19 | |
| 20 | inherit pkgconfig autotools systemd features_check |
| 21 | |
| 22 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 23 | |
| 24 | SYSTEMD_SERVICE_${PN} = "firmwared.service" |
| 25 | |
| 26 | do_configure_prepend() { |
| 27 | ${S}/autogen.sh |
| 28 | } |
| 29 | |
| 30 | do_install_append() { |
| 31 | install -d ${D}${systemd_system_unitdir} |
| 32 | install -m 0644 ${WORKDIR}/firmwared.service ${D}${systemd_system_unitdir} |
| 33 | sed -i -e 's,@BINDIR@,${bindir},g' ${D}${systemd_system_unitdir}/firmwared.service |
| 34 | } |