Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for reading mod-like audio files" |
| 2 | HOMEPAGE = "http://modplug-xmms.sf.net" |
| 3 | |
| 4 | LICENSE = "PD" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c9182faa1f7c316f7b97d404bcbe3685" |
| 6 | |
| 7 | SRC_URI = "${SOURCEFORGE_MIRROR}/modplug-xmms/libmodplug-${PV}.tar.gz" |
Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame] | 8 | SRC_URI[md5sum] = "5ba16981e6515975e9a68a58d5ba69d1" |
| 9 | SRC_URI[sha256sum] = "457ca5a6c179656d66c01505c0d95fafaead4329b9dbaa0f997d00a3508ad9de" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | |
| 11 | inherit autotools pkgconfig |
| 12 | |
| 13 | EXTRA_OECONF = "--disable-option-checking" |
| 14 | |
| 15 | # NOTE: autotools_stage_all does nothing here, we need to do it manually |
| 16 | do_install_append() { |
| 17 | install -d ${D}${includedir}/libmodplug |
| 18 | install -m 0644 ${S}/src/modplug.h ${D}${includedir}/libmodplug |
| 19 | install -m 0644 ${S}/src/modplug.h ${D}${includedir}/ |
| 20 | } |