Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "VPX multi-format codec" |
| 2 | DESCRIPTION = "The BSD-licensed libvpx reference implementation provides en- and decoders for VP8 and VP9 bitstreams." |
| 3 | HOMEPAGE = "http://www.webmproject.org/code/" |
| 4 | BUGTRACKER = "http://code.google.com/p/webm/issues/list" |
| 5 | SECTION = "libs/multimedia" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 6 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4" |
| 9 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 10 | SRCREV = "7ec7a33a081aeeb53fed1a8d87e4cbd189152527" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | SRC_URI += "git://chromium.googlesource.com/webm/libvpx;protocol=https \ |
| 12 | file://libvpx-configure-support-blank-prefix.patch \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | # ffmpeg links with this and fails |
| 18 | # sysroots/armv4t-oe-linux-gnueabi/usr/lib/libvpx.a(vpx_encoder.c.o)(.text+0xc4): unresolvable R_ARM_THM_CALL relocation against symbol `memcpy@@GLIBC_2.4' |
| 19 | ARM_INSTRUCTION_SET = "arm" |
| 20 | |
| 21 | CFLAGS += "-fPIC" |
| 22 | |
| 23 | export CC |
| 24 | export LD = "${CC}" |
| 25 | |
| 26 | VPXTARGET_armv5te = "armv5te-linux-gcc" |
| 27 | VPXTARGET_armv6 = "armv6-linux-gcc" |
| 28 | VPXTARGET_armv7a = "armv7-linux-gcc" |
| 29 | VPXTARGET ?= "generic-gnu" |
| 30 | |
| 31 | CONFIGUREOPTS = " \ |
| 32 | --target=${VPXTARGET} \ |
| 33 | --enable-vp9 \ |
| 34 | --enable-libs \ |
| 35 | --disable-install-docs \ |
| 36 | --disable-static \ |
| 37 | --enable-shared \ |
| 38 | --prefix=${prefix} \ |
| 39 | --libdir=${libdir} \ |
| 40 | --size-limit=16384x16384 \ |
| 41 | " |
| 42 | |
| 43 | do_configure() { |
| 44 | ${S}/configure ${CONFIGUREOPTS} |
| 45 | } |
| 46 | |
| 47 | do_install() { |
| 48 | oe_runmake install DESTDIR=${D} |
| 49 | chown -R root:root ${D} |
| 50 | } |