Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \ |
| 2 | The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \ |
| 3 | It includes all features of 4.4BSD C shell, plus a command-line editor, \ |
| 4 | programmable word completion, spelling correction and more." |
| 5 | |
| 6 | HOMEPAGE = "http://www.tcsh.org/" |
| 7 | LICENSE = "BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://Copyright;md5=575cf2715c3bf894e1f79aec1d4eaaf5" |
| 9 | SECTION = "base" |
| 10 | DEPENDS = "ncurses virtual/crypt gettext-native" |
| 11 | SRC_URI = " \ |
| 12 | https://astron.com/pub/${BPN}/${BP}.tar.gz \ |
| 13 | file://0001-Enable-system-malloc-on-all-linux.patch \ |
| 14 | file://0002-Add-debian-csh-scripts.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | " |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 16 | SRC_URI[md5sum] = "fa2b347fa9ae866eb036e6e4bb85fe1a" |
| 17 | SRC_URI[sha256sum] = "eb16356243218c32f39e07258d72bf8b21e62ce94bb0e8a95e318b151397e231" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'" |
| 20 | inherit autotools |
| 21 | |
| 22 | do_compile_prepend() { |
| 23 | oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' gethost |
| 24 | } |
| 25 | |
| 26 | do_install_append () { |
| 27 | oe_runmake install.man DESTDIR=${D} |
| 28 | |
| 29 | install -d ${D}${base_bindir} |
| 30 | ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh |
| 31 | ln -s /usr/bin/tcsh ${D}${base_bindir}/csh |
| 32 | install -d ${D}${sysconfdir}/csh/login.d |
| 33 | install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir} |
| 34 | install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el |
| 35 | } |
| 36 | |
| 37 | FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el" |
| 38 | |
| 39 | |
| 40 | pkg_postinst_${PN} () { |
| 41 | #!/bin/sh -e |
| 42 | echo /usr/bin/tcsh >> $D/etc/shells |
| 43 | echo /usr/bin/csh >> $D/etc/shells |
| 44 | } |