Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A graphical front-end for gcov" |
| 2 | HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php" |
| 3 | DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \ |
| 4 | tool gcov. It collects gcov data for multiple source files and creates \ |
| 5 | HTML pages containing the source code annotated with coverage information. \ |
| 6 | It also adds overview pages for easy navigation within the file structure. \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 7 | LCOV supports statement, function and branch coverage measurement." |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | LICENSE = "GPL-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 10 | |
| 11 | RDEPENDS_${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | libjson-perl \ |
| 13 | libperlio-gzip-perl \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | perl \ |
| 15 | perl-module-filehandle \ |
| 16 | perl-module-getopt-std \ |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 17 | perl-module-digest-md5 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | perl-module-digest-sha \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | perl-module-constant \ |
| 20 | perl-module-cwd \ |
| 21 | perl-module-errno \ |
| 22 | perl-module-file-basename \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | perl-module-file-copy \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | perl-module-file-find \ |
| 25 | perl-module-file-path \ |
| 26 | perl-module-file-spec \ |
| 27 | perl-module-file-spec-functions \ |
| 28 | perl-module-file-spec-unix \ |
| 29 | perl-module-file-temp \ |
| 30 | perl-module-getopt-long \ |
| 31 | perl-module-list-util \ |
| 32 | perl-module-mro \ |
| 33 | perl-module-overload \ |
| 34 | perl-module-overloading \ |
| 35 | perl-module-overload-numbers \ |
| 36 | perl-module-parent \ |
| 37 | perl-module-pod-usage \ |
| 38 | perl-module-posix \ |
| 39 | perl-module-re \ |
| 40 | perl-module-safe \ |
| 41 | perl-module-scalar-util \ |
| 42 | perl-module-term-cap \ |
| 43 | perl-module-text-parsewords \ |
| 44 | perl-module-tie-hash \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 45 | " |
| 46 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 47 | RDEPENDS_${PN}_append_class-target = " \ |
| 48 | gcov \ |
| 49 | gcov-symlinks \ |
| 50 | " |
| 51 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 52 | SRC_URI = " \ |
| 53 | http://downloads.sourceforge.net/ltp/${BP}.tar.gz \ |
| 54 | file://0001-geninfo-Add-intermediate-text-format-support.patch \ |
| 55 | file://0002-geninfo-Add-intermediate-JSON-format-support.patch \ |
| 56 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 57 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 58 | SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1" |
| 59 | SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 60 | |
| 61 | do_install() { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 62 | oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir} |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 63 | } |
| 64 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 65 | BBCLASSEXTEND = "native nativesdk" |