Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for controlling team network device" |
| 2 | HOMEPAGE = "http://www.libteam.org/" |
| 3 | SECTION = "libs/network" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 7 | |
| 8 | DEPENDS = "libnl libdaemon jansson" |
| 9 | |
| 10 | SRC_URI = "git://github.com/jpirko/libteam \ |
| 11 | file://0001-include-sys-select.h-for-fd_set-definition.patch \ |
| 12 | file://0002-teamd-Re-adjust-include-header-order.patch \ |
| 13 | file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ |
| 14 | file://0001-team_basic_test.py-use-python3-interpreter.patch \ |
| 15 | file://run-ptest \ |
| 16 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 17 | SRCREV = "3ee12c6d569977cf1cd30d0da77807a07aa77158" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit autotools pkgconfig ptest |
| 22 | |
| 23 | FILES_${PN} = "${libdir}/libteam${SOLIBS} \ |
| 24 | " |
| 25 | |
| 26 | PACKAGES += "${PN}-dctl ${PN}-utils" |
| 27 | FILES_${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \ |
| 28 | " |
| 29 | FILES_${PN}-utils = "${bindir}/bond2team \ |
| 30 | ${bindir}/teamd \ |
| 31 | ${bindir}/teamdctl \ |
| 32 | ${bindir}/teamnl \ |
| 33 | " |
| 34 | |
| 35 | RDEPENDS_${PN}-utils = "bash" |
| 36 | RDEPENDS_${PN}-ptest = "python3-core" |
| 37 | |
| 38 | do_install_ptest() { |
| 39 | install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/ |
| 40 | } |