Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0337b116233da4616ae9fdb130bf6f1a" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=8.3.x \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | file://0001-support-cross-compiling.patch \ |
| 10 | file://0001-explicitly-set-compile-options.patch \ |
| 11 | " |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 12 | SRCREV ?= "92933b86574b9c80764bf52c357ed29e1ef53382" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | inherit setuptools3 |
| 15 | |
| 16 | DEPENDS += " \ |
| 17 | zlib \ |
| 18 | jpeg \ |
| 19 | tiff \ |
| 20 | freetype \ |
| 21 | lcms \ |
| 22 | openjpeg \ |
| 23 | " |
| 24 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 25 | RDEPENDS_${PN} += " \ |
| 26 | ${PYTHON_PN}-misc \ |
| 27 | ${PYTHON_PN}-logging \ |
| 28 | ${PYTHON_PN}-numbers \ |
| 29 | " |
| 30 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 31 | CVE_PRODUCT = "pillow" |
| 32 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | S = "${WORKDIR}/git" |
| 34 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 35 | RPROVIDES_${PN} += "python3-imaging" |
| 36 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | BBCLASSEXTEND = "native" |