Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "An advanced menu editor" |
| 2 | HOMEPAGE = "https://launchpad.net/menulibre" |
| 3 | SECTION = "x11/graphics" |
| 4 | LICENSE = "GPLv3" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 6 | |
| 7 | DEPENDS = " \ |
| 8 | python3-distutils-extra-native \ |
| 9 | intltool-native \ |
| 10 | " |
| 11 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 12 | inherit distutils3 gtk-icon-cache features_check |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | REQUIRED_DISTRO_FEATURES = "x11" |
| 15 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | SRC_URI = "https://launchpad.net/menulibre/2.2/${PV}/+download/${BPN}-${PV}.tar.gz" |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 17 | SRC_URI[md5sum] = "8460ea844a5998c5f722bccb5ce8627a" |
| 18 | SRC_URI[sha256sum] = "5b3ef8e6073d584f6accf282fa1eb649185ee42eb22fab70231491c7377d7e8f" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
| 20 | do_compile() { |
| 21 | } |
| 22 | |
| 23 | do_install_append() { |
| 24 | sed -i 's:${D}::g' ${D}${datadir}/applications/menulibre.desktop |
| 25 | sed -i 's:share/share:share:g' ${D}${PYTHON_SITEPACKAGES_DIR}/menulibre_lib/menulibreconfig.py |
| 26 | } |
| 27 | |
| 28 | FILES_${PN} += " \ |
| 29 | ${datadir}/applications \ |
| 30 | ${datadir}/menulibre \ |
| 31 | ${datadir}/icons \ |
| 32 | " |
| 33 | |
| 34 | RDEPENDS_${PN} += " \ |
| 35 | gtk+3 \ |
| 36 | gtksourceview3 \ |
| 37 | python3-pygobject \ |
| 38 | gnome-menus3 \ |
| 39 | python3-unixadmin \ |
| 40 | python3-psutil \ |
| 41 | " |