Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Thumbnail service implementing the thumbnail management D-Bus specification" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 2 | SECTION = "x11/libs" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | DEPENDS = "freetype gdk-pixbuf poppler curl xfce4-dev-tools-native libxml2 libgsf" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | |
| 7 | inherit xfce gtk-doc |
| 8 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "9b0b7fed0c64041733d490b1b307297984629d0dd85369749617a8766850af66" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 10 | |
| 11 | INSANE_SKIP_${PN} = "dev-so" |
| 12 | |
| 13 | PACKAGECONFIG ??= "" |
| 14 | PACKAGECONFIG[gstreamer-thumbnailer] = "--enable-gstreamer-thumbnailer,--disable-gstreamer-thumbnailer,gstreamer1.0 gstreamer1.0-plugins-base" |
| 15 | |
| 16 | do_install_append() { |
| 17 | # Makefile seems to race on creation of symlink. So ensure creation here |
| 18 | # until fixed properly |
| 19 | ln -sf tumbler-xdg-cache.so ${D}${libdir}/tumbler-1/plugins/cache/tumbler-cache-plugin.so |
| 20 | } |
| 21 | |
| 22 | FILES_${PN} += "${datadir}/dbus-1/services \ |
| 23 | ${libdir}/tumbler-1/tumblerd \ |
| 24 | ${libdir}/tumbler-1/plugins/*.so \ |
| 25 | ${libdir}/tumbler-1/plugins/cache/*.so \ |
| 26 | " |
| 27 | |
| 28 | FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | ${libdir}/tumbler-1/plugins/cache/*.la \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | " |