Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "TPM2 Access Broker & Resource Manager" |
| 2 | DESCRIPTION = "This is a system daemon implementing the TPM2 access \ |
| 3 | broker (TAB) & Resource Manager (RM) spec from the TCG. The daemon (tpm2-abrmd) \ |
| 4 | is implemented using Glib and the GObject system. In this documentation and \ |
| 5 | in the code we use `tpm2-abrmd` and `tabrmd` interchangeably. \ |
| 6 | " |
| 7 | SECTION = "security/tpm" |
| 8 | |
| 9 | LICENSE = "BSD-2-Clause" |
| 10 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da" |
| 11 | |
| 12 | DEPENDS = "autoconf-archive dbus glib-2.0 tpm2-tss glib-2.0-native \ |
| 13 | libtss2 libtss2-mu libtss2-tcti-device libtss2-tcti-mssim" |
| 14 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 15 | SRC_URI = "\ |
| 16 | git://github.com/tpm2-software/tpm2-abrmd.git \ |
| 17 | file://tpm2-abrmd-init.sh \ |
| 18 | file://tpm2-abrmd.default \ |
| 19 | " |
| 20 | |
Andrew Geissler | 9d3cc05 | 2021-03-31 13:36:22 -0500 | [diff] [blame] | 21 | SRCREV = "4f332013a02c422e186c4aaf127ab6a40b996028" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools pkgconfig systemd update-rc.d useradd |
| 26 | |
| 27 | SYSTEMD_PACKAGES += "${PN}" |
| 28 | SYSTEMD_SERVICE_${PN} = "tpm2-abrmd.service" |
| 29 | SYSTEMD_AUTO_ENABLE_${PN} = "disable" |
| 30 | |
| 31 | INITSCRIPT_NAME = "${PN}" |
| 32 | INITSCRIPT_PARAMS = "start 99 2 3 4 5 . stop 19 0 1 6 ." |
| 33 | |
| 34 | USERADD_PACKAGES = "${PN}" |
| 35 | GROUPADD_PARAM_${PN} = "tss" |
| 36 | USERADD_PARAM_${PN} = "--system -M -d /var/lib/tpm -s /bin/false -g tss tss" |
| 37 | |
| 38 | PACKAGECONFIG ?="${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd', '', d)}" |
| 39 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir}, --with-systemdsystemunitdir=no" |
| 40 | |
| 41 | do_install_append() { |
| 42 | install -d "${D}${sysconfdir}/init.d" |
| 43 | install -m 0755 "${WORKDIR}/tpm2-abrmd-init.sh" "${D}${sysconfdir}/init.d/tpm2-abrmd" |
| 44 | |
| 45 | install -d "${D}${sysconfdir}/default" |
| 46 | install -m 0644 "${WORKDIR}/tpm2-abrmd.default" "${D}${sysconfdir}/default/tpm2-abrmd" |
| 47 | } |
| 48 | |
| 49 | FILES_${PN} += "${libdir}/systemd/system-preset \ |
| 50 | ${datadir}/dbus-1" |
| 51 | |
| 52 | RDEPENDS_${PN} += "tpm2-tss" |
| 53 | |
| 54 | BBCLASSEXTEND = "native" |