blob: 8831d84cb1101da44a1f8d94c9144c19b77484e0 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "Simple construction, analysis and modification of binary data."
2HOMEPAGE = "https://github.com/scott-griffiths/bitstring"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=661f450e2c0aef39b4b15597333444a7"
5
Patrick Williamsda295312023-12-05 16:48:56 -06006SRC_URI[sha256sum] = "1b47c84644a961ba8503db2bba8a5965ab53e81474becdf0a18383b5b5f3f795"
Patrick Williams2a254922023-08-11 09:48:11 -05007
8PYPI_PACKAGE = "bitstring"
9
10inherit pypi python_poetry_core
11
12RDEPENDS:${PN} = "\
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-mmap \
16 ${PYTHON_PN}-numbers \
17"
18
19BBCLASSEXTEND = "native nativesdk"